LACP configuration

This post shows example how to configure LACP and verify that it works properly. Link Aggregation Control Protocol (LACP) is open standard protocol for aggregating links into one virtual channel (in comparision to PAgP which is similar but Cisco proprietary protocol).

Configuration

Configure the interfaces on both ends

win-xserw002#conf t
win-xserw002(config)#interface range fastEthernet 0/21-22
win-xserw002(config-if-range)#switchport nonegotiate
win-xserw002(config-if-range)#switchport mode trunk
win-xserw002(config-if-range)#switchport trunk allowed vlan 1-100
win-xserw002(config-if-range)#channel-group 1 mode active
win-xserw002(config-if-range)#no shutdown
win-xserw002(config-if-range)#exit

win-xserw002(config)#interface port-channel 1
win-xserw002(config-if)#switchport nonegotiate
win-xserw002(config-if)#switchport mode trunk
win-xserw002(config-if)#switchport trunk allowed vlan 1-100
win-xserw002(config-if)#no shutdown
win-xserw003#conf t
win-xserw003(config)#interface range fastEthernet 0/21-22
win-xserw003(config-if-range)#switchport nonegotiate
win-xserw003(config-if-range)#switchport mode trunk
win-xserw003(config-if-range)#switchport trunk allowed vlan 1-100
win-xserw003(config-if-range)#channel-group 1 mode passive
win-xserw003(config-if-range)#no shutdown
win-xserw003(config-if-range)#exit

win-xserw003(config)#interface port-channel 1
win-xserw003(config-if)#switchport nonegotiate
win-xserw003(config-if)#switchport mode trunk
win-xserw003(config-if)#switchport trunk allowed vlan 1-100
win-xserw003(config-if)#no shutdown

Note that the configuration is similar for both ends but one end is configured in active mode and the second end is configured in passive mode. If you configure LACP between switch and server then usually you configure the switch in active mode.

Every change you apply to the port-channel interface will be applied [copied] to all physical interfaces which belong to this etherchannel. So if you want to change (for example) allowed vlan list on the trunk port make the change only on the port-channel interface.

If you change the settings on your physical interface the changes will not be applied to the port-channel interface. In this case the port-channel may also fail because the physical interfaces should be configured identical.

Veryfication

If you configure the port-channel properly then you should see the similar output

win-xserw002#show etherchannel 1 summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Fa0/21(P)   Fa0/22(P)

win-xserw002#

The “P” flag indicates that the interface is part of the port-channel and works properly.

Troubleshooting

If you don’t see the “P” flag it means that something is wrong.

Basically the “I” flag means that the port is not part of the channel end it functions normally (as if no port-channel was configured for this) – this port is up/up, forwards frame, takes part in spanning-tree, etc.

The “s” flags means that port is basically down (no frame forwarding, no spanning tree, etc.). It is part of the channel but it is suspended for some reason.

Your etherchannel should work if you configure all the interfaces in the same way (switchport mode [access/trunk], allowed vlans, speed, duplex, dtp, everything…).

If you need troubleshoot your configuration in more details use the following commands

show etherchannel 1 summary
show etherchannel 1 detail
show etherchannel 1 detail | include reason
show etherchannel 1 port
show interfaces fastEthernet 0/21 etherchannel

Leave a Reply

Your email address will not be published. Required fields are marked *